Absolutely Tech

[Solved] “is not co-installable with” errors on Ubuntu

By: Deepak Mittal

I installed 32bit wine on 64bit Kubuntu but for some reason it didn’t install properly so I tried reinstalling wine 64 bit and got the following error:

dpkg: error processing /var/cache/apt/archives/wine1.2_1.2.3-0ubuntu1~ppa1_amd64.deb (–unpack):
wine1.2: 1.2.3-0ubuntu1~ppa1 (Multi-Arch: no) is not co-installable with wine1.2:i386 1.2.3-0ubuntu1~ppa1 (Multi-Arch: no) which is currently installed

You can’t simply remove 32bit wine using apt-get remove wine1.2. To fix the issue suffix the package name with ‘:i386′.

Therefore, I solved the problem by:

sudo dpkg -r wine1.2:i386

Category: Ubuntu (Linux)

Tagged: , ,

  • Diakas

    Thank You!!!

  • Forbergmec

    If I had googled for this “is not co-installable with” query right away, I’d saved 2 hours. Be your day tomorrow be a blessed one. THANKS !

=