Absolutely Tech

[SOLVED] ‘Error at offset’ error in unserialize()

I came across this weird error in unserialize() where it refused to unserialize the serialized data. After hours of trying different things to solve it, finally converting the encoding worked.

The solution to the problem is to use the following function instead of unserialize():

function safe_unserialize($str){
       return unserialize( trim( mb_convert_encoding( $str,'auto','UTF-8' ) ) );
}

Cheers!

[Solved] apt-get “is to be installed” errors in Ubuntu

This class of error means the dependency is of different version than required. I tried to install deluge-console but it gave me the following error:

deluge-console : Depends: deluge-common (= 1.3.0-0ubuntu1) but 1.3.0-1~getdeb1 is to be installed

The error is not that self-explanatory. Here the deluge-common version required by deluge-console is 1.3.0-0 but 1.3.0-1 is installed. This means that I have newer version of a dependency required by the application I am trying to install.

Fortunately, you can force the version in apt-get:

sudo apt-get install deluge-common=1.3.0-0ubuntu1

I forced an older version, downgrading the package. This fixed the error for me and I could successfully install deluge-console after that.

This method can be applied to fix problems in other applications as well.

Cheers!

[SOLVED] Error ‘dpkg: error processing <filename> (--unpack) trying to overwrite…

Recently I got this error after installing VLC on Ubuntu 10.10 Maverick Meerkat. Not really remembering what caused the error to be triggered in the first place, it became very difficult to find a solution for it.
When I executed sudo apt-get upgrade to upgrade my packages, it told me there was some issues and I needed to execute sudo apt-get -f install to fix them. I did as advised but it produced the following error:

Reading package lists… Done
Building dependency tree
Reading state information… Done
Correcting dependencies… Done
The following extra packages will be installed:
vlc vlc-nox
Suggested packages:
mozilla-plugin-vlc videolan-doc
The following packages will be upgraded:
vlc vlc-nox
2 upgraded, 0 newly installed, 0 to remove and 198 not upgraded.
66 not fully installed or removed.
Need to get 0B/5,258kB of archives.
After this operation, 229kB of additional disk space will be used.
Do you want to continue [Y/n]? y
WARNING: The following packages cannot be authenticated!
vlc vlc-nox
Install these packages without verification [y/N]? y
(Reading database … 206759 files and directories currently installed.)
Preparing to replace vlc 1.1.0-1~ppa1~maverick (using …/vlc_1.1.0-1ubuntu1_i386.deb) …
Unpacking replacement vlc …
dpkg: error processing /var/cache/apt/archives/vlc_1.1.0-1ubuntu1_i386.deb (–unpack):
trying to overwrite ‘/usr/lib/vlc/plugins/access/libxcb_screen_plugin.so’, which is also in package vlc-nox 1.1.0-1~ppa1~maverick
dpkg-deb: subprocess paste killed by signal (Broken pipe)
Preparing to replace vlc-nox 1.1.0-1~ppa1~maverick (using …/vlc-nox_1.1.0-1ubuntu1_i386.deb) …
Unpacking replacement vlc-nox …
dpkg: error processing /var/cache/apt/archives/vlc-nox_1.1.0-1ubuntu1_i386.deb (–unpack):
trying to overwrite ‘/usr/lib/vlc/lua/playlist/anevia_streams.luac’, which is also in package vlc 1.1.0-1~ppa1~maverick
dpkg-deb: subprocess paste killed by signal (Broken pipe)
Errors were encountered while processing:
/var/cache/apt/archives/vlc_1.1.0-1ubuntu1_i386.deb
/var/cache/apt/archives/vlc-nox_1.1.0-1ubuntu1_i386.deb
E: Sub-process /usr/bin/dpkg returned an error code (1)

After some time of googling and head-scratching, I finally found a solution and it wasn’t that difficult either.
To fix it just note down the path of files which are causing the trouble. From the above mentioned error, we can clearly see that there are these two files causing the error:
Read the rest of this entry »

[SOLVED] Media Playing issues in VLC in Ubuntu 10.10 Maverick Meerkat

I had problems with playing media files in VLC in Maverick Meerkat. Other players (SMPlayer) seemed to work fine. VLC gave errors like:

“No suitable decoder module: VLC does not support the audio or video format “XVID”. VLC Unfortunately there is no way for you to fix this.”

And

“No suitable decoder module: VLC does not support the audio or video format “H264”. VLC Unfortunately there is no way for you to fix this.”

Found this solution written by my friend khattam but it didn’t solve my issue. It still gave errors.

I solved the errors after removing libavutil-extra-49, libavutil-extra-50 and installing libavutil50, libavutil49.

sudo apt-get install libavutil50 libavutil49

This will automatically remove the libavutil-extra-49 and libavutil-extra-50 and install libavutil50 and libavutil49 over it. It solved the issue for me.

Click here if this doesn’t solve your issue.

Cheers!

[SOLVED] Unable to boot due to GNOME Power Manager error

If you are getting the following error while booting into ubuntu, its most likely due to low disk space in root drive:

“The configuration defaults for GNOME Power Manager have not been installed correctly. Please contact your computer administrator.”

Behavior:
After you enter the password on login screen, it takes you back to login screen making you unable to log in.

Solution:
However, you can still get to terminal. Press Ctrl+Alt+F1 to drop to terminal from login screen. Enter your username and password and execute the following command:
Read the rest of this entry »

[Solved] “Error saving media attachment.” error in WordPress

WordPress might give this error on uploading an image from media library. It means that wordpress isn’t able to save your file.

It is really easy to fix. However, this may not work for all:

Read the rest of this entry »