Absolutely Tech

[Solved] “is not co-installable with” errors on Ubuntu

I installed 32bit wine on 64bit Kubuntu but for some reason it didn’t install properly so I tried reinstalling wine 64 bit and got the following error:

dpkg: error processing /var/cache/apt/archives/wine1.2_1.2.3-0ubuntu1~ppa1_amd64.deb (–unpack):
wine1.2: 1.2.3-0ubuntu1~ppa1 (Multi-Arch: no) is not co-installable with wine1.2:i386 1.2.3-0ubuntu1~ppa1 (Multi-Arch: no) which is currently installed

You can’t simply remove 32bit wine using apt-get remove wine1.2. To fix the issue suffix the package name with ‘:i386′.

Therefore, I solved the problem by:

sudo dpkg -r wine1.2:i386

[Solved] apt-get “is to be installed” errors in Ubuntu

This class of error means the dependency is of different version than required. I tried to install deluge-console but it gave me the following error:

deluge-console : Depends: deluge-common (= 1.3.0-0ubuntu1) but 1.3.0-1~getdeb1 is to be installed

The error is not that self-explanatory. Here the deluge-common version required by deluge-console is 1.3.0-0 but 1.3.0-1 is installed. This means that I have newer version of a dependency required by the application I am trying to install.

Fortunately, you can force the version in apt-get:

sudo apt-get install deluge-common=1.3.0-0ubuntu1

I forced an older version, downgrading the package. This fixed the error for me and I could successfully install deluge-console after that.

This method can be applied to fix problems in other applications as well.

Cheers!

[SOLVED] “Ignoring file ‘.distUpgrade’ / ‘.save’ in directory ‘/etc/apt/sources.list.d/’ as it has an invalid filename extension” on Ubuntu 10.10

Recently apt-get update started throwing notices which read:

Ignoring file 'opera.list.distUpgrade' in directory '/etc/apt/sources.list.d/' as it has an invalid filename extension
Ignoring file 'opera.list.save' in directory '/etc/apt/sources.list.d/' as it has an invalid filename extension

It occured because sources.list.d directory isn’t supposed to contain files with .distupgrade and .save extensions, but since I upgraded my distribution from 10.04, backup copies of the source files were made with .distUpgrade appended to them. Similarly .save files were not supposed to be in the directory which made it throw this error. Fortunately you can suppress this error by executing the following command:

sudo sh -c "echo 'Dir::Ignore-Files-Silently:: \"(.save|.distupgrade)$\";' > /etc/apt/apt.conf.d/99ignoresave"

This will suppress the error. Next time you run sudo apt-get update you wouldn’t see those errors.

UPDATE: Apt 0.8.8 seems to have fixed the issue as mentionedby _khAttAm_ in comments. You can install it from Unstable repositories.

Cheers!

[SOLVED] Error ‘dpkg: error processing <filename> (--unpack) trying to overwrite…

Recently I got this error after installing VLC on Ubuntu 10.10 Maverick Meerkat. Not really remembering what caused the error to be triggered in the first place, it became very difficult to find a solution for it.
When I executed sudo apt-get upgrade to upgrade my packages, it told me there was some issues and I needed to execute sudo apt-get -f install to fix them. I did as advised but it produced the following error:

Reading package lists… Done
Building dependency tree
Reading state information… Done
Correcting dependencies… Done
The following extra packages will be installed:
vlc vlc-nox
Suggested packages:
mozilla-plugin-vlc videolan-doc
The following packages will be upgraded:
vlc vlc-nox
2 upgraded, 0 newly installed, 0 to remove and 198 not upgraded.
66 not fully installed or removed.
Need to get 0B/5,258kB of archives.
After this operation, 229kB of additional disk space will be used.
Do you want to continue [Y/n]? y
WARNING: The following packages cannot be authenticated!
vlc vlc-nox
Install these packages without verification [y/N]? y
(Reading database … 206759 files and directories currently installed.)
Preparing to replace vlc 1.1.0-1~ppa1~maverick (using …/vlc_1.1.0-1ubuntu1_i386.deb) …
Unpacking replacement vlc …
dpkg: error processing /var/cache/apt/archives/vlc_1.1.0-1ubuntu1_i386.deb (–unpack):
trying to overwrite ‘/usr/lib/vlc/plugins/access/libxcb_screen_plugin.so’, which is also in package vlc-nox 1.1.0-1~ppa1~maverick
dpkg-deb: subprocess paste killed by signal (Broken pipe)
Preparing to replace vlc-nox 1.1.0-1~ppa1~maverick (using …/vlc-nox_1.1.0-1ubuntu1_i386.deb) …
Unpacking replacement vlc-nox …
dpkg: error processing /var/cache/apt/archives/vlc-nox_1.1.0-1ubuntu1_i386.deb (–unpack):
trying to overwrite ‘/usr/lib/vlc/lua/playlist/anevia_streams.luac’, which is also in package vlc 1.1.0-1~ppa1~maverick
dpkg-deb: subprocess paste killed by signal (Broken pipe)
Errors were encountered while processing:
/var/cache/apt/archives/vlc_1.1.0-1ubuntu1_i386.deb
/var/cache/apt/archives/vlc-nox_1.1.0-1ubuntu1_i386.deb
E: Sub-process /usr/bin/dpkg returned an error code (1)

After some time of googling and head-scratching, I finally found a solution and it wasn’t that difficult either.
To fix it just note down the path of files which are causing the trouble. From the above mentioned error, we can clearly see that there are these two files causing the error:
Read the rest of this entry »

[Solved] ‘Public key is not available’ error on apt-get update in Ubuntu

I came across this error while doing sudo apt-get update

W: GPG error: http://ppa.launchpad.net karmic Release: The following signatures couldn’t be verified because the public key is not available: NO_PUBKEY 5A9BF3BB4E5E19B8
W: GPG error: http://ppa.launchpad.net karmic Release: The following signatures couldn’t be verified because the public key is not available: NO_PUBKEY 9ABD05E22847688C

Read the rest of this entry »

Installing applications (Using synaptic package manager and terminal)

Applications is the key element of a computer. Without applications/softwares, computer is useless. Ubuntu has a pretty good software installation mechanism. All the softwares are at one place in Synaptic Package Manager which. This makes it easier to install applications. Instead of browsing the application website and downloading it from there and then installing it, all the applications are at one place. Just click on the application, mark it and you have it installed without any need of your intervention.

This is by far the best thing I liked in Ubuntu. You can access the synaptic package manager from System->Administration->Synaptic Package Manager. Type the application name and it will search as you type. To install an application, just right click on the application and select ‘Mark for installation’ and click on Apply. Your application will be downloaded and installed right away.

To install the same application using terminal, you can note down the exact name of the application as it appears in the Synaptic Package manager and in the terminal type:
sudo apt-get install package-name

Type in your password and your application will be installed after downloading.

In the default setup, there are most of the important repositories already added.

Repositories are collection of software which is at one place. If you add a repository in the source list, the applications available in the repository will be available in Synaptic Package Manager.

The source file is in the path /etc/apt/sources.list
You can add or remove repositories in this file.

That was a brief explanation about the application installation procedure on Ubuntu.

I hope you liked it.

Cheers!